CVE-2022-25345

Uncontrolled Resource Consumption in @discordjs/opus in npm/@discordjs/opus

Identifiers

GHSA-rvgf-69j7-xh78, CVE-2022-25345

Package Slug

npm/@discordjs/opus

Vulnerability

Uncontrolled Resource Consumption in @discordjs/opus

Description

All versions of package @discordjs/opus is vulnerable to Denial of Service (DoS) when trying to encode using an encoder with zero channels, or a non-initialized buffer. This leads to a hard crash.

Affected Versions

All versions up to 0.7.0

Solution

Unfortunately, there is no solution available yet.

Last Modified

2022-06-21

source