CVE-2022-31142

Observable Discrepancy in npm/@fastify/bearer-auth

Identifiers

GHSA-376v-xgjx-7mfr, CVE-2022-31142

Package Slug

npm/@fastify/bearer-auth

Vulnerability

Observable Discrepancy

Description

@fastify/bearer-auth is a Fastify plugin to require bearer Authorization headers. @fastify/bearer-auth prior to versions 7.0.2 and 8.0.1 does not securely use crypto.timingSafeEqual. A malicious attacker could estimate the length of one valid bearer token. According to the corresponding RFC 6750, the bearer token has only base64 valid characters, reducing the range of characters for a brute force attack. Version 7.0.2 and 8.0.1 of @fastify/bearer-auth contain a patch. There are currently no known workarounds. The package fastify-bearer-auth, which covers versions 6.0.3 and prior, is also vulnerable starting at version 5.0.1. Users of fastify-bearer-auth should upgrade to a patched version of @fastify/bearer-auth.

Affected Versions

All versions before 7.0.2, version 8.0.0

Solution

Upgrade to versions 7.0.2, 8.0.1 or above.

Last Modified

2022-07-26

source