CVE-2021-39168

Improper Privilege Management in npm/@openzeppelin/contracts

Identifier

CVE-2021-39168

Package Slug

npm/@openzeppelin/contracts

Vulnerability

Improper Privilege Management

Description

OpenZepplin is a library for smart contract development. Further details about the vulnerability will be disclosed at a later date. As a workaround revoke the executor role from accounts not strictly under the team's control. We recommend revoking all executors that are not also proposers. When applying this mitigation, ensure there is at least one proposer and executor remaining.

Affected Versions

All versions starting from 3.3.0 before 3.4.2, all versions starting from 4.0.0 before 4.3.1

Solution

Upgrade to versions 3.4.2, 4.3.1 or above.

Last Modified

2021-09-03

source