CVE-2022-31153

Incorrect Authorization in npm/@openzeppelin/contracts

Identifiers

CVE-2022-31153, GHSA-8mjr-jr5h-q2xr

Package Slug

npm/@openzeppelin/contracts

Vulnerability

Incorrect Authorization

Description

OpenZeppelin Contracts for Cairo is a library for contract development written in Cairo for StarkNet, a decentralized ZK Rollup. Version 0.2.0 is vulnerable to an error that renders account contracts unusable on live networks. This issue affects all accounts (vanilla and ethereum flavors) in the v0.2.0 release of OpenZeppelin Contracts for Cairo, which are not allow listed on StarkNet mainnet. Only goerli deployments of v0.2.0 accounts are affected. This faulty behavior is not observed in StarkNet's testing framework. This bug has been patched in v0.2.1.

Affected Versions

Version 0.2.0

Solution

Upgrade to version 2.3.0 or above.

Last Modified

2022-07-26

source