CVE-2022-31170

Improper Input Validation in npm/@openzeppelin/contracts-upgradeable

Identifiers

GHSA-qh9x-gcfh-pcrw, CVE-2022-31170

Package Slug

npm/@openzeppelin/contracts-upgradeable

Vulnerability

Improper Input Validation

Description

OpenZeppelin Contracts is a library for smart contract development. Versions 4.0.0 until 4.7.1 is vulnerable to ERC165Checker reverting instead of returning false. ERC165Checker.supportsInterface is designed to always successfully return a boolean, and under no circumstance revert. However, an incorrect assumption about Solidity 0.8's abi.decode allows some cases to revert, given a target contract that does not implement EIP-165 as expected, specifically if it returns a value other than 0 or 1. The contracts that may be affected are those that use ERC165Checker to check for support for an interface and then handle the lack of support in a way other than reverting. The issue was patched in version 4.7.1.

Affected Versions

All versions starting from 4.0.0 before 4.7.1

Solution

Upgrade to version 4.7.1 or above.

Last Modified

2022-07-26

source