CVE-2021-3807

Inefficient Regular Expression Complexity in npm/ansi-regex

Identifier

CVE-2021-3807

Package Slug

npm/ansi-regex

Vulnerability

Inefficient Regular Expression Complexity

Description

ansi-regex is vulnerable to Inefficient Regular Expression Complexity

Affected Versions

All versions starting from 3.0.0 before 5.0.1, all versions starting from 6.0.0 before 6.0.1

Solution

Upgrade to versions 5.0.1, 6.0.1 or above.

Last Modified

2021-09-30

source