CVE-2021-45293

Improper Restriction of Operations within the Bounds of a Memory Buffer in npm/binaryen

Identifiers

CVE-2021-45293

Package Slug

npm/binaryen

Vulnerability

Improper Restriction of Operations within the Bounds of a Memory Buffer

Description

A Denial of Service vulnerability exists in Binaryen due to an Invalid memory address dereference in wasm::WasmBinaryBuilder::visitLet.

Affected Versions

Version 103

Solution

Upgrade to version 104 or above.

Last Modified

2022-01-05

source