Identifier

CVE-2020-8244

Package Slug

npm/bl

Vulnerability

Out-of-bounds Read

Description

A buffer over-read vulnerability exists in bl which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Affected Versions

All versions before 2.2.1, all versions starting from 3.0.0 before 3.0.1, all versions starting from 4.0.0 before 4.0.3

Solution

Upgrade to versions 2.2.1, 3.0.1, 4.0.3 or above.

Last Modified

2020-09-04

source