CVE-2022-24429

Code injection via SVG file in convert-svg-core in npm/convert-svg-core

Identifiers

GHSA-54px-mhwv-5v8x, CVE-2022-24429

Package Slug

npm/convert-svg-core

Vulnerability

Code injection via SVG file in convert-svg-core

Description

The package convert-svg-core before 0.6.3 is vulnerable to Arbitrary Code Injection when using a specially crafted SVG file. An attacker can read arbitrary files from the file system and then show the file content as a converted PNG file.

Affected Versions

All versions before 0.6.3

Solution

Upgrade to version 0.6.3 or above.

Last Modified

2022-06-17

source