CVE-2021-39157

Improper Handling of Exceptional Conditions in npm/detect-character-encoding

Identifier

CVE-2021-39157

Package Slug

npm/detect-character-encoding

Vulnerability

Improper Handling of Exceptional Conditions

Description

detect-character-encoding is an open source character encoding inspection library. In detect-character-encoding, data matching no charset causes the Node.js process to crash. No workaround are available and all users should update to resolve this issue.

Affected Versions

All versions before 0.7.0

Solution

Upgrade to version 0.7.0 or above.

Last Modified

2021-09-02

source