CVE-2022-29257

Improper Input Validation in npm/electron

Identifiers

GHSA-77xc-hjv8-ww97, CVE-2022-29257

Package Slug

npm/electron

Vulnerability

Improper Input Validation

Description

Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows attackers who have control over a given apps update server / update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components. This kind of attack would require significant privileges in a potential victim's own auto updating infrastructure and the ease of that attack entirely depends on the potential victim's infrastructure security. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. There are no known workarounds.

Affected Versions

All versions before 15.5.0, all versions starting from 16.0.0 before 16.2.0, all versions starting from 17.0.0 before 17.2.0, all versions starting from 18.0.0-beta.1 up to 18.0.0-beta.5

Solution

Upgrade to versions 15.5.0, 16.2.0, 17.2.0, 18.0.0-beta.6 or above. Note: 18.0.0-beta.6 may be an unstable version. Use caution.

Last Modified

2022-06-17

source