CVE-2020-28498

Use of a Broken or Risky Cryptographic Algorithm in npm/elliptic

Identifier

CVE-2020-28498

Package Slug

npm/elliptic

Vulnerability

Use of a Broken or Risky Cryptographic Algorithm

Description

The package elliptic is vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.

Affected Versions

All versions before 6.5.4

Solution

Upgrade to version 6.5.4 or above.

Last Modified

2021-02-09

source