CVE-2020-28501

Uncontrolled Ressource Consumption in npm/es6-crawler-detect

Identifier

CVE-2020-28501

Package Slug

npm/es6-crawler-detect

Vulnerability

Uncontrolled Ressource Consumption

Description

No limitation of user agent string length supplied to regex operators.

Affected Versions

All versions before 3.1.3

Solution

Upgrade to version 3.1.3 or above.

Last Modified

2021-03-26

source