CVE-2022-29220

Insufficient Verification of Data Authenticity in npm/fastify

Identifiers

CVE-2022-29220, GHSA-v5vr-h3xq-8v6w

Package Slug

npm/fastify

Vulnerability

Insufficient Verification of Data Authenticity

Description

github-action-merge-dependabot is an action that automatically approves and merges dependabot pull requests (PRs). Prior to version 3.2.0, github-action-merge-dependabot does not check if a commit created by dependabot is verified with the proper GPG key. There is just a check if the actor is set to dependabot[bot] to determine if the PR is a legit PR. Theoretically, an owner of a seemingly valid and legit action in the pipeline can check if the PR is created by dependabot and if their own action has enough permissions to modify the PR in the pipeline. If so, they can modify the PR by adding a second seemingly valid and legit commit to the PR, as they can set arbitrarily the username and email in for commits in git. Because the bot only checks if the actor is valid, it would pass the malicious changes through and merge the PR automatically, without getting noticed by project maintainers. It would probably not be possible to determine where the malicious commit came from, as it would only say dependabot[bot] and the corresponding email-address. Version 3.2.0 contains a patch for this issue.

Affected Versions

All versions before 3.2.0

Solution

Upgrade to version 3.2.0 or above.

Last Modified

2022-06-17

source