CVE-2021-43843

Uncontrolled Resource Consumption in npm/jsx-slack

Identifiers

CVE-2021-43843, GHSA-hp68-xhvj-x6j6, GHSA-55xv-f85c-248q

Package Slug

npm/jsx-slack

Vulnerability

Uncontrolled Resource Consumption

Description

jsx-slack is a package for building JSON objects for Slack block kit surfaces from JSX. The maintainers found the patch for CVE-2021-43838 in jsx-slack v4.5.1 is insufficient tfor protection from a Regular Expression Denial of Service (ReDoS) attack. If an attacker can put a lot of JSX elements into <blockquote> tag with including multibyte characters, an internal regular expression for escaping characters may consume an excessive amount of computing resources. v4.5.1 passes the test against ASCII characters but misses the case of multibyte characters. jsx-slack v4.5.2 has updated regular expressions for escaping blockquote characters to prevent catastrophic backtracking. It is also including an updated test case to confirm rendering multiple tags in <blockquote> with multibyte characters.

Affected Versions

All versions before 4.5.2

Solution

Upgrade to version 4.5.2 or above.

Last Modified

2022-01-04

source