Improper Input Validation in npm/next-auth


CVE-2022-35924, GHSA-xv97-c62v-4587

Package Slug



Improper Input Validation


NextAuth.js is a complete open source authentication solution for Next.js applications. next-auth users who are using the EmailProvider either in versions before 4.10.3 or 3.29.10 are affected. If an attacker could forge a request that sent a comma-separated list of emails (eg.:, to the sign-in endpoint, NextAuth.js would send emails to both the attacker and the victim's e-mail addresses. The attacker could then login as a newly created user with the email being, This means that basic authorization like email.endsWith("") in the signIn callback would fail to communicate a threat to the developer and would let the attacker bypass authorization, even with an address. This vulnerability has been patched in v4.10.3 and v3.29.10 by normalizing the email value that is sent to the sign-in endpoint before accessing it anywhere else. We also added a normalizeIdentifier callback on the EmailProvider configuration, where you can further tweak your requirements for what your system considers a valid e-mail address. (E.g.: strict RFC2821 compliance). Users are advised to upgrade. There are no known workarounds for this vulnerability. If for some reason you cannot upgrade, you can normalize the incoming request using Advanced Initialization.

Affected Versions

All versions before 3.29.10, all versions starting from 4.0.0 before 4.10.3


Upgrade to versions 3.29.10, 4.10.3 or above.

Last Modified