CVE-2021-23434

Access of Resource Using Incompatible Type (Type Confusion) in npm/object-path

Identifier

CVE-2021-23434

Package Slug

npm/object-path

Vulnerability

Access of Resource Using Incompatible Type (Type Confusion)

Description

A type confusion vulnerability can lead to a bypass of CVE-2020-15256 when the path components used in the path parameter are arrays. In particular, the condition currentPath === '__proto__' returns false if currentPath is ['__proto__']. This is because the === operator returns always false when the type of the operands is different.

Affected Versions

All versions before 0.11.6

Solution

Upgrade to version 0.11.6 or above.

Last Modified

2021-09-03

source