CVE-2021-39138

Improper Authentication in npm/parse-server

Identifier

CVE-2021-39138

Package Slug

npm/parse-server

Vulnerability

Improper Authentication

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Developers can use the REST API to signup users and also allow users to login anonymously., when an anonymous user is first signed up using REST, the server creates session incorrectly. Particularly, the authProvider field in _Session class under createdWith shows the user logged in creating a password. If a developer later depends on the createdWith field to provide a different level of access between a password user and anonymous user, the server incorrectly classified the session type as being created with a password. The server does not currently use createdWith to make decisions about internal functions, so if a developer is not using createdWith directly, they are not affected. The vulnerability only affects users who depend on createdWith by using it directly. As a workaround, do not use the createdWith Session field to make decisions if one allows anonymous login.

Affected Versions

All versions before 4.5.1

Solution

Upgrade to version 4.5.1 or above.

Last Modified

2021-09-03

source