CVE-2021-41109

Exposure of Sensitive Information to an Unauthorized Actor in npm/parse-server

Identifier

CVE-2021-41109

Package Slug

npm/parse-server

Vulnerability

Exposure of Sensitive Information to an Unauthorized Actor

Description

For regular (non-LiveQuery) queries, the session token is removed from the response, but for LiveQuery payloads it is currently not. If a user has a LiveQuery subscription on the Parse.User class, all session tokens created during user sign-ups will be broadcast as part of the LiveQuery payload.

Affected Versions

All versions before 4.10.4

Solution

Upgrade to version 4.10.4 or above.

Last Modified

2021-10-10

source