CVE-2022-24901

Authentication bypass and denial of service (DoS) vulnerabilities in Apple Game Center auth adapter in npm/parse-server

Identifiers

GHSA-qf8x-vqjv-92gr, CVE-2022-24901

Package Slug

npm/parse-server

Vulnerability

Authentication bypass and denial of service (DoS) vulnerabilities in Apple Game Center auth adapter

Description

Improper validation of the Apple certificate URL in the Apple Game Center authentication adapter allows attackers to bypass authentication, making the server vulnerable to DoS attacks. The vulnerability has been fixed by improving the URL validation and adding additional checks of the resource the URL points to before downloading it.

Affected Versions

All versions before 4.10.10, all versions starting from 5.0.0 before 5.2.1

Solution

Upgrade to versions 4.10.10, 5.2.1 or above.

Last Modified

2022-05-05

source