CVE-2022-31083

Improper Authentication in npm/parse-server

Identifiers

GHSA-rh9j-f5f8-rvgc, CVE-2022-31083

Package Slug

npm/parse-server

Vulnerability

Improper Authentication

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 4.10.11 and 5.2.2, the certificate in the Parse Server Apple Game Center auth adapter not validated. As a result, authentication could potentially be bypassed by making a fake certificate accessible via certain Apple domains and providing the URL to that certificate in an authData object. Versions 4.0.11 and 5.2.2 prevent this by introducing a new rootCertificateUrl property to the Parse Server Apple Game Center auth adapter which takes the URL to the root certificate of Apple's Game Center authentication certificate. If no value is set, the rootCertificateUrl property defaults to the URL of the current root certificate as of May 27, 2022. Keep in mind that the root certificate can change at any time and that it is the developer's responsibility to keep the root certificate URL up-to-date when using the Parse Server Apple Game Center auth adapter. There are no known workarounds for this issue.

Affected Versions

All versions before 4.10.11, all versions starting from 5.0.0 before 5.2.2

Solution

Upgrade to versions 4.10.11, 5.2.2 or above.

Last Modified

2022-06-19

source