CVE-2021-21267

Uncontrolled Resource Consumption in npm/schema-inspector

Identifier

CVE-2021-21267

Package Slug

npm/schema-inspector

Vulnerability

Uncontrolled Resource Consumption

Description

Schema-Inspector is an open-source tool to sanitize and validate JS objects (npm package schema-inspector). In, email address validation is vulnerable to a denial-of-service attack where some input will freeze the program or web browser page executing the code. This affects any current schema-inspector users using any version to validate email addresses. Users who do not do email validation, and instead do other types of validation (like string min or max length, etc), are not affected. Users should upgrade to, which uses a regex expression that isn't vulnerable to ReDoS.

Affected Versions

All versions before 2.0.0

Solution

Upgrade to version 2.0.0 or above.

Last Modified

2021-03-26

source