CVE-2022-31051

Exposure of Sensitive Information to an Unauthorized Actor in npm/semantic-release

Identifiers

CVE-2022-31051, GHSA-x2pg-mjhr-2m5x

Package Slug

npm/semantic-release

Vulnerability

Exposure of Sensitive Information to an Unauthorized Actor

Description

semantic-release is an open source npm package for automated version management and package publishing. In affected versions secrets that would normally be masked by semantic-release can be accidentally disclosed if they contain characters that are excluded from uri encoding by encodeURI. Occurrence is further limited to execution contexts where push access to the related repository is not available without modifying the repository url to inject credentials. Users are advised to upgrade. Users unable to upgrade should ensure that secrets that do not contain characters that are excluded from encoding with encodeURI when included in a URL are already masked properly.

Affected Versions

All versions starting from 17.0.4 before 19.0.3

Solution

Upgrade to version 19.0.3 or above.

Last Modified

2022-06-10

source