CVE-2021-4306

Inefficient Regular Expression Complexity in npm/terminal-kit

Identifiers

GHSA-wxgh-8gmr-3qh3, CVE-2021-4306

Package Slug

npm/terminal-kit

Vulnerability

Inefficient Regular Expression Complexity

Description

A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.

Affected Versions

All versions before 2.1.8

Solution

Upgrade to version 2.1.8 or above.

Last Modified

2023-01-13

source