CVE-2021-32736

Improperly Controlled Modification of Dynamically-Determined Object Attributes in npm/think-helper

Identifier

CVE-2021-32736

Package Slug

npm/think-helper

Vulnerability

Improperly Controlled Modification of Dynamically-Determined Object Attributes

Description

think-helper defines a set of helper functions for ThinkJS. The software receives input from an upstream component that specifies attributes that are to be initialized or updated in an object, but it does not properly control modifications of attributes of the object prototype.

Affected Versions

All versions before 1.1.3

Solution

Upgrade to version 1.1.3 or above.

Last Modified

2021-07-12

source