CVE-2022-31150

Improper Neutralization of CRLF Sequences ('CRLF Injection') in npm/undici

Identifiers

CVE-2022-31150, GHSA-3cvr-822r-rqcc

Package Slug

npm/undici

Vulnerability

Improper Neutralization of CRLF Sequences ('CRLF Injection')

Description

undici is an HTTP/1.1 client, written from scratch for Node.js. It is possible to inject CRLF sequences into request headers in undici in versions less than 5.7.1. A fix was released in version 5.8.0. Sanitizing all HTTP headers from untrusted sources to eliminate \r\n is a workaround for this issue.

Affected Versions

All versions before 5.8.0

Solution

Upgrade to version 5.8.0 or above.

Last Modified

2022-07-26

source