CVE-2022-31151

Uncleared cookies on cross-host / cross-origin redirect in npm/undici

Identifiers

CVE-2022-31151, GHSA-q768-x9m6-m9qp

Package Slug

npm/undici

Vulnerability

Uncleared cookies on cross-host / cross-origin redirect

Description

Authorization headers are cleared on cross-origin redirect. However, cookie headers which are sensitive headers and are official headers found in the spec, remain uncleared. There are active users using cookie headers in undici. This may lead to accidental leakage of cookie to a 3rd-party site or a malicious attacker who can control the redirection target (ie. an open redirector) to leak the cookie to the 3rd party site. This was patched in v5.7.1. By default, this vulnerability is not exploitable. Do not enable redirections, i.e. maxRedirections: 0 (the default).

Affected Versions

All versions before 5.7.1

Solution

Upgrade to version 5.8.0 or above.

Last Modified

2022-07-26

source