CVE-2022-32210

Improper Certificate Validation in npm/undici

Identifiers

CVE-2022-32210, GHSA-pgw7-wx7w-2w33

Package Slug

npm/undici

Vulnerability

Improper Certificate Validation

Description

Undici.ProxyAgent never verifies the remote server's certificate, and always exposes all request & response data to the proxy. This unexpectedly means that proxies can MitM all HTTPS traffic, and if the proxy's URL is HTTP then it also means that nominally HTTPS requests are actually sent via plain-text HTTP between Undici and the proxy server.

Affected Versions

All versions starting from 4.8.2 before 5.5.1

Solution

Upgrade to version 5.5.1 or above.

Last Modified

2022-07-27

source