CVE-2020-26296

Cross-site Scripting in npm/vega

Identifier

CVE-2020-26296

Package Slug

npm/vega

Vulnerability

Cross-site Scripting

Description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine.

Affected Versions

All versions before 5.17.3

Solution

Upgrade to version 5.17.3 or above.

Last Modified

2021-01-07

source