CVE-2019-10761

Uncontrolled Recursion in npm/vm2

Identifiers

GHSA-wf5x-cr3r-xr77, CVE-2019-10761

Package Slug

npm/vm2

Vulnerability

Uncontrolled Recursion

Description

This affects the package vm2 before 3.6.11. It is possible to trigger a RangeError exception from the host rather than the "sandboxed" context by reaching the stack call limit with an infinite recursion. The returned object is then used to reference the mainModule property of the host code running the script allowing it to spawn a child_process and execute arbitrary code.

Affected Versions

All versions before 3.6.11

Solution

Upgrade to version 3.6.11 or above.

Last Modified

2022-07-26

source