CVE-2021-43045

Allocation of Resources Without Limits or Throttling in Apache Avro in nuget/Apache.Avro

Identifiers

CVE-2021-43045, GHSA-868x-rg4c-cjqg

Package Slug

nuget/Apache.Avro

Vulnerability

Allocation of Resources Without Limits or Throttling in Apache Avro

Description

A vulnerability in the .NET SDK of Apache Avro allows an attacker to allocate excessive resources, potentially causing a denial-of-service attack. This issue affects .NET applications using Apache Avro and prior versions. Users should update to which addresses this issue.

Affected Versions

All versions before 1.11.0

Solution

Upgrade to version 1.11.0 or above.

Last Modified

2022-01-11

source