Identifier

CVE-2020-15170

Package Slug

nuget/Creekdream.Configuration.Apollo

Vulnerability

Improper Input Validation

Description

apollo-adminservice does not implement access controls. If users expose apollo-adminservice to internet(which is not recommended), there are potential security issues since apollo-adminservice is designed to work in intranet and it does not have access control built-in. Malicious hackers may access apollo-adminservice apis directly to access/edit the application's configurations. To fix the potential issue without upgrading, simply follow the advice that do not expose apollo-adminservice to internet.

Affected Versions

All versions before 1.7.1

Solution

Upgrade to version 1.7.1 or later

Last Modified

2020-09-11

source