CVE-2021-31819

Deserialization of Untrusted Data in nuget/Halibut

Identifier

CVE-2021-31819

Package Slug

nuget/Halibut

Vulnerability

Deserialization of Untrusted Data

Description

In Halibut there is a deserialisation vulnerability that could allow remote code execution on systems that already trust each other based on certificate verification.

Affected Versions

All versions before 4.4.7

Solution

Upgrade to version 4.4.7 or above.

Last Modified

2021-10-01

source