CVE-2022-29864

Uncontrolled Resource Consumption in OPCFoundation.NetStandard.Opc.Ua in nuget/OPCFoundation.NetStandard.Opc.Ua

Identifiers

GHSA-vhfw-v69p-crcw, CVE-2022-29864

Package Slug

nuget/OPCFoundation.NetStandard.Opc.Ua

Vulnerability

Uncontrolled Resource Consumption in OPCFoundation.NetStandard.Opc.Ua

Description

OPC UA .NET Standard Stack 1.04.368 allows a remote attacker to cause a server to crash via a large number of messages that trigger Uncontrolled Resource Consumption.

Affected Versions

All versions up to 1.4.368.53

Solution

Upgrade to version 1.4.368.58 or above.

Last Modified

2022-06-19

source