CVE-2022-29865

Incorrect Implementation of Authentication Algorithm in OPCFoundation.NetStandard.Opc.Ua in nuget/OPCFoundation.NetStandard.Opc.Ua

Identifiers

GHSA-fvxf-r9fw-49pc, CVE-2022-29865

Package Slug

nuget/OPCFoundation.NetStandard.Opc.Ua

Vulnerability

Incorrect Implementation of Authentication Algorithm in OPCFoundation.NetStandard.Opc.Ua

Description

OPC UA .NET Standard Stack allows a remote attacker to bypass the application authentication check via crafted fake credentials.

Affected Versions

All versions up to 1.4.368.53

Solution

Upgrade to version 1.4.368.58 or above.

Last Modified

2022-06-19

source