CVE-2006-5031

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in packagist/cakephp/cakephp

Identifiers

GHSA-rw73-xmpv-j5x2, CVE-2006-5031

Package Slug

packagist/cakephp/cakephp

Vulnerability

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Description

Directory traversal vulnerability in app/webroot/js/vendors.php in Cake Software Foundation CakePHP before 1.1.8.3544 allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter, followed by a filename ending with "%00" and a .js filename.

Affected Versions

All versions starting from 1.0.1.2708 before 1.1.8.3544

Solution

Upgrade to version 1.1.8.3544 or above.

Last Modified

2023-01-16

source