CVE-2023-22727

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in packagist/cakephp/cakephp

Identifiers

CVE-2023-22727, GHSA-6g8q-qfpv-57wp

Package Slug

packagist/cakephp/cakephp

Vulnerability

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Description

CakePHP is a development framework for PHP web apps. In affected versions the Cake\Database\Query::limit() and Cake\Database\Query::offset() methods is vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.

Affected Versions

All versions starting from 4.2.0 before 4.2.12, all versions starting from 4.3.0 before 4.3.11, all versions starting from 4.4.0 before 4.4.10

Solution

Upgrade to versions 4.2.12, 4.3.11, 4.4.10 or above.

Last Modified

2023-01-23

source