Inclusion of Functionality from Untrusted Control Sphere in packagist/composer/composer


GHSA-7c6p-848j-wh5h, CVE-2024-24821

Package Slug



Inclusion of Functionality from Untrusted Control Sphere


Composer is a dependency Manager for the PHP language. In affected versions several files within the local working directory are included during the invocation of Composer and in the context of the executing user. As such, under certain conditions arbitrary code execution may lead to local privilege escalation, provide lateral user movement or malicious code execution when Composer is invoked within a directory with tampered files. All Composer CLI commands are affected, including composer.phar's self-update. The following scenarios are of high risk: Composer being run with sudo, Pipelines which may execute Composer on untrusted projects, Shared environments with developers who run Composer individually on the same project. This vulnerability has been addressed in versions 2.7.0 and 2.2.23. It is advised that the patched versions are applied at the earliest convenience. Where not possible, the following should be addressed: Remove all sudo composer privileges for all users to mitigate root privilege escalation, and avoid running Composer within an untrusted directory, or if needed, verify that the contents of vendor/composer/InstalledVersions.php and vendor/composer/installed.php do not include untrusted code. A reset can also be done on these files by the following:sh rm vendor/composer/installed.php vendor/composer/InstalledVersions.php composer install --no-scripts --no-plugins

Affected Versions

All versions starting from 2.0.0-alpha1 before 2.2.23, all versions starting from 2.3.0-rc1 before 2.7.0


Upgrade to versions 2.2.23, 2.7.0 or above.

Last Modified