CVE-2021-37626

Improper Control of Generation of Code ('Code Injection') in packagist/contao/contao

Identifiers

GHSA-r6mv-ppjc-4hgr, CVE-2021-37626

Package Slug

packagist/contao/contao

Vulnerability

Improper Control of Generation of Code ('Code Injection')

Description

Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.

Affected Versions

All versions starting from 4.0.0 before 4.4.56, all versions starting from 4.5.0 before 4.9.18, all versions starting from 4.10.0 before 4.11.7

Solution

Upgrade to versions 4.4.56, 4.9.18, 4.11.7 or above.

Last Modified

2024-02-06

source