CVE-2022-31140

Generation of Error Message Containing Sensitive Information in packagist/cuyz/valinor

Identifiers

GHSA-5pgm-3j3g-2rc7, CVE-2022-31140

Package Slug

packagist/cuyz/valinor

Vulnerability

Generation of Error Message Containing Sensitive Information

Description

Valinor is a PHP library that helps to map any input into a strongly-typed value object structure. Prior to version 0.12.0, Valinor can use Throwable#getMessage() when it should not have permission to do so. This is a problem with cases such as an SQL exception showing an SQL snippet, a database connection exception showing database IP address/username/password, or a timeout detail / out of memory detail. Attackers could use this information for potential data exfiltration, denial of service attacks, enumeration attacks, etc. Version 0.12.0 contains a patch for this vulnerability.

Affected Versions

All versions before 0.12.0

Solution

Upgrade to version 0.12.0 or above.

Last Modified

2022-07-26

source