CVE-2021-20750

Cross-site Scripting in packagist/ec-cube/ec-cube

Identifier

CVE-2021-20750

Package Slug

packagist/ec-cube/ec-cube

Vulnerability

Cross-site Scripting

Description

Cross-site scripting vulnerability in EC-CUBE EC-CUBE to (EC-CUBE 3 series) and EC-CUBE to (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.

Affected Versions

All versions starting from 3.0.0 before 3.0.18, all versions starting from 4.0.0 before 4.0.5

Solution

Upgrade to versions 3.0.18, 4.0.5 or above.

Last Modified

2021-07-12

source