CVE-2022-41876

ezplatform-graphql GraphQL queries can expose password hashes in packagist/ezsystems/ezplatform-graphql

Identifiers

CVE-2022-41876, GHSA-c7pc-pgf6-mfh5

Package Slug

packagist/ezsystems/ezplatform-graphql

Vulnerability

ezplatform-graphql GraphQL queries can expose password hashes

Description

ezplatform-graphql is a GraphQL server implementation for Ibexa DXP and Ibexa Open Source. Versions prior to 2.3.12 and 1.0.13 are subject to Insecure Storage of Sensitive Information. Unauthenticated GraphQL queries for user accounts can expose password hashes of users that have created or modified content, typically administrators and editors. This issue has been patched in versions 2.3.12, and 1.0.13 on the 1.X branch. Users unable to upgrade can remove the "passwordHash" entry from "src/bundle/Resources/config/graphql/User.types.yaml" in the GraphQL package, and other properties like hash type, email, login if you prefer.

Affected Versions

All versions starting from 1.0.0 before 1.0.13, version 2.0.0

Solution

Upgrade to versions 1.0.13, 2.0.1 or above.

Last Modified

2022-11-13

source