CVE-2022-1457

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in packagist/facturascripts/facturascripts

Identifiers

GHSA-8wp2-vxpg-xcvp, CVE-2022-1457

Package Slug

packagist/facturascripts/facturascripts

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

Stored XSS in title parameter executing at EditUser Page & EditProducto page in GitHub repository neorazorx/facturascripts prior to 2022.04. Cross-site scripting attacks can have devastating consequences. Attackers can masquerade as authorized users via session cookies, allowing them to perform any action allowed by the user account.

Affected Versions

All versions before 2022.04

Solution

Upgrade to version 2022.04 or above.

Last Modified

2022-05-01

source