CVE-2022-41938

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in packagist/flarum/core

Identifiers

GHSA-7x4w-j98p-854x, CVE-2022-41938

Package Slug

packagist/flarum/core

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

Flarum is an open source discussion platform. Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after v1.5 and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. All communities running Flarum from v1.5.0 to v1.6.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.6.2. All communities running Flarum from v1.5.0 to v1.6.1 have to upgrade as soon as possible to v1.6.2. There are no known workarounds for this issue.

Affected Versions

All versions starting from 1.5.0 before 1.6.2

Solution

Upgrade to version 1.6.2 or above.

Last Modified

2022-11-22

source