CVE-2022-31042

Exposure of Sensitive Information to an Unauthorized Actor in packagist/guzzlehttp/guzzle

Identifiers

CVE-2022-31042, GHSA-f2wf-25xc-69c9

Package Slug

packagist/guzzlehttp/guzzle

Vulnerability

Exposure of Sensitive Information to an Unauthorized Actor

Description

Guzzle is an open source PHP HTTP client. In affected versions the Cookie headers on requests are sensitive information. On making a request using the https scheme to a server which responds with a redirect to a URI with the http scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the Cookie header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any Cookie header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies that it deems should be there. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach to use your own redirect middleware, rather than ours. If you do not require or expect redirects to be followed, one should simply disable redirects all together.

Affected Versions

All versions before 6.5.7, all versions starting from 7.0.0 before 7.4.4

Solution

Upgrade to versions 6.5.7, 7.4.4 or above.

Last Modified

2022-06-10

source