CVE-2022-31043

Exposure of Sensitive Information to an Unauthorized Actor in packagist/guzzlehttp/guzzle

Identifiers

CVE-2022-31043, GHSA-w248-ffj2-4v5q

Package Slug

packagist/guzzlehttp/guzzle

Vulnerability

Exposure of Sensitive Information to an Unauthorized Actor

Description

Guzzle is an open source PHP HTTP client. In affected versions Authorization headers on requests are sensitive information. On making a request using the https scheme to a server which responds with a redirect to a URI with the http scheme, we should not forward the Authorization header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, https to http downgrades does not result in the Authorization header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.

Affected Versions

All versions before 6.5.7, all versions starting from 7.0.0 before 7.4.4

Solution

Upgrade to versions 6.5.7, 7.4.4 or above.

Last Modified

2022-06-10

source