CVE-2021-21015

OS Command Injection in packagist/magento/community-edition

Identifier

CVE-2021-21015

Package Slug

packagist/magento/community-edition

Vulnerability

OS Command Injection

Description

Magento is vulnerable to an OS command injection via the customer attribute save controller. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Affected Versions

All versions before 2.3.6, all versions starting from 2.4.0 up to 2.4.1

Solution

Upgrade to versions 2.3.6, 2.4.1-p1 or above.

Last Modified

2021-02-18

source