CVE-2021-21019

XPath Injection in packagist/magento/community-edition

Identifier

CVE-2021-21019

Package Slug

packagist/magento/community-edition

Vulnerability

XPath Injection

Description

Magento is vulnerable to XML injection in the Widgets module. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Affected Versions

All versions before 2.3.6, all versions starting from 2.4.0 up to 2.4.1

Solution

Upgrade to versions 2.3.6, 2.4.1-p1 or above.

Last Modified

2021-02-18

source