CVE-2022-31158

Use of a Broken or Risky Cryptographic Algorithm in packagist/packbackbooks/lti-1-3-php-library

Identifiers

GHSA-5p73-qg2v-383h, CVE-2022-31158

Package Slug

packagist/packbackbooks/lti-1-3-php-library

Vulnerability

Use of a Broken or Risky Cryptographic Algorithm

Description

LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.

Affected Versions

All versions before 5.0

Solution

Upgrade to version 5.0 or above.

Last Modified

2022-07-26

source