CVE-2024-24574

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in packagist/phpmyfaq/phpmyfaq

Identifiers

GHSA-7m8g-fprr-47fx, CVE-2024-24574

Package Slug

packagist/phpmyfaq/phpmyfaq

Vulnerability

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)

Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.

Affected Versions

All versions before 3.2.5

Solution

Upgrade to version 3.2.5 or above.

Last Modified

2024-02-06

source